При установки gcc необходимо установить ряд зависимостей, если это делать вручную, то можно наткнуться на такую ошибку:

error: Failed dependencies:

kernel-headers is needed by glibc-headers-2.3.4-2.39.i386

kernel-headers >= 2.2.1 is needed by glibc-headers-2.3.4-2.39.i386

Но пакета kernel-headers нет для данной версии.

Решение будет простым, установить дополнительно пакет:

glibc-kernheaders-2.4-9.1.100.EL.i386.rpm